Main Contents

Publipostage et format des dates

Thématiques

Lorsque l’on réalise une fusion dans Word à partir du résultat d’une requête Diovital exporté au format Excel, les dates sont affichées au format anglais JJ/MM/AA, peu pratique sous nos climats.

Word et Excel faisant un peu ce qu’ils veulent, nous avons trouvé deux-trois bricolages pour y remédier, la solution 1bis ayant notre préférence :

1) Transformer les données dans le fichier Excel

Pour chaque colonne de type date qui doit être utilisée dans le modèle de document Word, créer une autre colonne dont la valeur est déterminée par une formule de ce genre;

=TEXTE(H2; « jj/mm/aaaa »)

Il suffit ensuite de baser le modèle sur ces nouvelles colonnes, plutôt que sur celles contenant les dates, et ça devrait marcher

1 bis) Variante du même, à partir de Diovital

On peut faire à peu près ça directement depuis le requêteur: il ne faut pas sélectionner le champ date directement, mais une version formatée à l’aide d’une formule de ce genre:

format(dt_don, « dd/MM/yyyy »)

Et par ailleurs, il ne faut pas exporter les résultats en données brutes, mais en données liées. Sinon, Excel va transformer à nouveau le texte en date, et on se retrouvera au même point.

2) Utiliser les options idoines dans Word

Il est possible de créer des champs de fusion en indiquant des options de mise en forme, mais c’est un peu branlant.

Pour ce faire, plutôt que d’utiliser la fonction « Insérer des champs de fusion », il faut créer les champs manuellement:

- Appuyer sur ctrl+F9 pour créer le champ « vide », ce qui devrait insérer une paire d’accolades sur fond gris au point d’insertion

- Entre les accolades, taper ça:

{MERGEFIELD [Nom du champ date] \@ « dd/MM/yyyy »}

Ici, par exemple:

{MERGEFIELD Date_de_début \@ « dd/MM/yyyy »}

Le problème, c’est qu’une fois fait, dès qu’on passe en mode publipostage pour vérifier les résultats, puis qu’on revient en mode conception, Word va afficher le champ comme un champ de fusion normal, càd simplement le nom du champ entre guillemets. Il conserve le format, mais si d’aventure on va modifier le champ via la fonction standard « Modification du champ », le format sera alors perdu.

16 mars 2009

Login


Feed